[Bug 400256] Re: Default language for "model" values hardcoded as 'en_US' should be configurable

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 400256] Re: Default language for "model" values hardcoded as 'en_US' should be configurable

Mariano Ruiz - EOC
We solve this [here](https://code.launchpad.net/~eoc/openobject-
server/6.1-overwrite_changes_translatable_fields) with a different
approach:

With the patch, all changes (calls to ``write`` method) made in no
'en_US' language will be written in 'en_US' too (in the table model).
Anyway, the behavior is not activated by default, you must be activate
it adding this key-value in the ``openerp-server.conf`` file:

    override_translated = True

--
You received this bug notification because you are a member of OpenERP
Framework Experts, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/400256

Title:
  Default language for "model" values hardcoded as 'en_US' should be
  configurable

Status in Odoo Server:
  Confirmed

Bug description:
  In the current v5.0, the default language for data strings in objects
  is hardcoded to be 'en_US' in the server code.

  This complicates usage when the main language in the company is not English.
  For example even in a company where all the business is done in French, you cannot change (and correct!) the value of a translatable field in the table, because the new value will be written to ir_translation instead when you don't use en_US.

  This is particularly disturbing in companies where English is not used
  at all.

  We should be able to change the default language from en_US to the
  locale of our choice, preferably at database creation time, or else in
  the server config file or command-line.

  This is only for data strings input by users ("model" values in
  ir_translate), and the default language for field names, help texts
  and other stuff must remain en_US.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openobject-server/+bug/400256/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~openerp-expert-framework
Post to     : [hidden email]
Unsubscribe : https://launchpad.net/~openerp-expert-framework
More help   : https://help.launchpad.net/ListHelp
Loading...